[Mono-bugs] [Bug 69273][Maj] New - Mono program crashes in Fedora Core 3

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Tue, 9 Nov 2004 10:17:25 -0500 (EST)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by ywwg@usa.net.


--- shadow/69273	2004-11-09 10:17:25.000000000 -0500
+++ shadow/69273.tmp.28624	2004-11-09 10:17:25.000000000 -0500
@@ -0,0 +1,66 @@
+Bug#: 69273
+Product: Mono: Runtime
+Version: 1.0
+OS Details: Fedora Core 3
+Status: NEW   
+Priority: Major
+Component: misc
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: ywwg@usa.net               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: Mono program crashes in Fedora Core 3
+Description of Problem:
+I've just updated to Fedora Core 3, and I reinstalled mono and gtk-sharp
+from source so I could run tomboy.  Tomboy previously worked perfectly in
+fc2.  Now, whenever I try to view a note I get a glibc detection error and
+Steps to reproduce the problem:
+1. run tomboy
+2. click on icon, select a note to view
+Actual Results:
+Creating Buffer for 'ToDo'...
+*** glibc detected *** double free or corruption: 0x089a6730 ***
+And now it's locked up and I have to kill mono.
+Expected Results:
+I should see a tomboy note!
+How often does this happen? 
+Additional Information:
+I'm filing this under mono's bugzilla because tomboy shouldn't be
+responsible for garbage collection, so mono must be at fault.
+Here's a piece of a backtrace, although I don't know if this helps:
+Program received signal SIGSEGV, Segmentation fault.
+[Switching to Thread -170386512 (LWP 7998)]
+0x0494e652 in std::__default_alloc_template<true, 0>::allocate () from
+(gdb) bt
+#0  0x0494e652 in std::__default_alloc_template<true, 0>::allocate () from
+#1  0x04954018 in std::string::_Rep::_S_create () from /usr/lib/libstdc++.so.5
+#2  0x049540ee in std::string::_Rep::_M_clone () from /usr/lib/libstdc++.so.5
+#3  0x04951d0d in std::string::reserve () from /usr/lib/libstdc++.so.5
+#4  0x04952074 in std::string::append () from /usr/lib/libstdc++.so.5
+#5  0x049542db in std::operator+<char, std::char_traits<char>,
+std::allocator<char> > ()
+   from /usr/lib/libstdc++.so.5
+#6  0x0082b655 in ?? ()
+#7  0xf5d7e840 in ?? ()
+#8  0xf5d7eb44 in ?? ()
+I also tried disabling glibc's detection methods, and it still locks up.