[Mono-bugs] [Bug 58746][Nor] Changed - equals sign is considered to be argument separator by Mono batch files

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Fri, 21 May 2004 05:08:14 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by gonzalo@ximian.com.


--- shadow/58746	2004-05-20 23:13:54.000000000 -0400
+++ shadow/58746.tmp.30002	2004-05-21 05:08:14.000000000 -0400
@@ -78,6 +78,13 @@
 Apparently the loop to store the command line parameters in the 
 MONOARGS env var does not handle equal signs well
 ------- Additional Comments From gert.driesen@pandora.be  2004-05-20 23:13 -------
 mmm, appears to be an issue with batch files in general ...
+------- Additional Comments From gonzalo@ximian.com  2004-05-21 05:08 -------
+It seems so. I tried to fix it by quoting %1 in the loop, but that
+breaks if you pass a quoted file name with spaces in it. So i guess
+this is a WONTFIX or at least a IDONTKNOWHOWTODOTHIS ;-).
+I tried googling for a while and couldn't figure out how to fix it.