[Mono-bugs] [Bug 58058][Blo] New - After install mcs won't run at all

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Wed, 5 May 2004 07:05:10 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by wdsenn@yahoo.com.


--- shadow/58058	2004-05-05 07:05:10.000000000 -0400
+++ shadow/58058.tmp.18020	2004-05-05 07:05:10.000000000 -0400
@@ -0,0 +1,58 @@
+Bug#: 58058
+Product: Mono: Compilers
+Version: unspecified
+OS Details: XP SP1A
+Status: NEW   
+Priority: Blocker
+Component: C#
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: wdsenn@yahoo.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: After install mcs won't run at all
+Please fill in this template when reporting a bug, unless you know what you
+are doing.
+Description of Problem:
+After running the installer mono-Beta1-win32-1.exe downloaded from the mono
+website. I ran mcs test.cs on a simple hello world and it complained that
+it Could not find assembly System.
+Steps to reproduce the problem:
+1. mcs test.cs
+or even just mcs with no argument
+Actual Results:
+** (D:\mono\lib\mono\1.0\mcs.exe:3888): WARNING **: Could not find assembly
+System, references from D:\mono\lib\mono\1.0\mcs.exe (assemblyref_index=1)
+     Major/Minor: 1,0
+     Build:       5000,0
+     Token:       b77a5c561934e089
+Unhandled Exception: System.NullReferenceException: Object reference not
+set to an instance of an object
+Expected Results:
+A successful execution on mcs
+How often does this happen? 
+every time
+Additional Information:
+The install notes are skimpy... When I first installed it complained that
+mscorlib.dll needed to be in C:\mono\mb\install\lib, so I copied it there
+and then it at least ran (I had to do this in 0.31 as well, but it worked
+after that in 0.31).
+Next I figured it needed to be on the path, so I added d:\mono\bin to the
+path and d:\mono\lib as well.
+Finally, I read a note about MONO_PATH, so I set it to d:\mono\lib in the
+absence of more compelling direction - to no effect.