[Mono-bugs] [Bug 61986][Min] New - assembler.exe doesn't handle --hb properly

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Mon, 26 Jul 2004 17:44:12 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by epicene@pobox.com.


--- shadow/61986	2004-07-26 17:44:12.000000000 -0400
+++ shadow/61986.tmp.8757	2004-07-26 17:44:12.000000000 -0400
@@ -0,0 +1,94 @@
+Bug#: 61986
+Product: Mono: Doctools
+Version: unspecified
+OS Details: 
+Status: NEW   
+Priority: Minor
+Component: Console
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: epicene@pobox.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: assembler.exe doesn't handle --hb properly
+NOTE: This bug isn't critical, and I've worked around it.
+Description of Problem:
+assembler.exe doesn't handle the --hb flag properly. I created some new
+make rules to generate a new monkeyguide, and it's clear that assembler.exe
+isn't picking up Documentation-new.xml, my new version of Documentation.xml.
+Steps to reproduce the problem:
+0. cvs up monkeyguide
+1. Notice the following rules in monkeyguide/makefile:
+# rules for new / rewritten monkeyguide
+new: monohb-new.tree monohb-new.zip
+monohb-new.tree monohb-new.zip: Documentation-new.xml new/en/index.html
+$(shell find new/en -name "*.html" )
+	xmllint --noout $?
+	cp Documentation-new.xml Documentation.xml # assembler.exe doesn't like
+other names
+	$(MONO) $(SOURCESDIR)/../assembler.exe --hb Documentation-new.xml --out
+Documentation-new.xml : mkmstoc.xsl toc2.xml
+	$(XSLTPROC) mkmstoc.xsl toc2.xml > Documentation-new.xml
+new/en/index.html : mkindex.xsl toc2.xml
+	$(XSLTPROC) mkindex.xsl toc2.xml > $@
+Comment out the line "cp Documentation-new.xml...." to display this bug.
+2. Run "make new". Get an error because assembler.exe isn't actually
+looking for the Documentation-new.xml we told it to look for.
+lightning ~/src/bleeding/mono/monkeyguide$ make new
+`which xsltproc` mkmstoc.xsl toc2.xml > Documentation-new.xml
+xmllint --noout Documentation-new.xml
+mono `Monodoc --get-sourcesdir`/../assembler.exe --hb Documentation-new.xml
+--out monohb-new
+Unhandled Exception: System.IO.FileNotFoundException: Could not find file
+in <0x00414> System.IO.FileStream:.ctor
+in <0x00044> System.IO.FileStream:.ctor
+in <0x000f8> (wrapper remoting-invoke-with-check)
+in <0x001ac> System.Xml.XmlUrlResolver:GetEntity
+in <0x00168> System.Xml.XmlTextReader:.ctor (string,System.Xml.XmlNameTable)
+in <0x00054> System.Xml.XmlTextReader:.ctor (string)
+in <0x00058> System.Xml.XmlDocument:Load (string)
+in <0x0007c> Monodoc.SimpleHandbookTOCParser:.ctor (Monodoc.Tree)
+in <0x00040> Monodoc.XhtmlProvider:PopulateTree (Monodoc.Tree)
+in <0x0084c> Monodoc.Assembler:Main (string[])
+make: *** [monohb-new.tree] Error 1
+3. Uncomment the "cp Documentation-new.xml Documentation.xml" line
+in makefile. Run "make new" again. Watch it succeed.
+Actual Results:
+ - Not generating documentation.
+Expected Results:
+ - Building the documentation in the new/ tree.
+How often does this happen? 
+- Every time I run it.