[Mono-bugs] [Bug 51592][Nor] New - libGC is broken on OS X

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Fri, 23 Jan 2004 16:21:44 -0500 (EST)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by lupus@ximian.com.


--- shadow/51592	2004-01-23 16:21:43.000000000 -0500
+++ shadow/51592.tmp.31184	2004-01-23 16:21:43.000000000 -0500
@@ -0,0 +1,88 @@
+Bug#: 51592
+Product: Mono/Runtime
+Version: unspecified
+OS: unknown
+OS Details: 10.3.1
+Status: NEW   
+Severity: Unknown
+Priority: Normal
+Component: misc
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: rshade@dvsconsulting.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: libGC is broken on OS X
+libGC is currently broken on OS X and all other BSDs.  I have tried using it under linux PPC 
+(gentoo) and have determined it not to be a PPC problem, but a BSD problem.  Googling for 
+the Boehm GC and BSD turns up many posts to the BSD mailing lists stating that there is a 
+------- Additional Comments From rshade@dvsconsulting.com  2003-12-02 13:15 -------
+Just a few additional notes, "make check" does work with 6.2 and the 6.3 alpha from 
+its homepage.  I have also tried using these instead of the included gc in the mono 
+CVS with the same result.
+------- Additional Comments From rshade@dvsconsulting.com  2003-12-02 13:38 -------
+The backtrace with a simple "hello world" app run with mint or mono is:
+Starting program: /usr/local/bin/mint hello.exe
+Reading symbols for shared libraries +warning: Trying to remove a section from the 
+ordered section list that did not exist at 0x0.
+++++. done
+** (hello.exe:28382): WARNING **: Shared memory sanity check failed.
+** (hello.exe:28382): WARNING **: Failed to attach shared memory! Falling back to 
+non-shared handles
+Program received signal EXC_BAD_ACCESS, Could not access memory.
+[Switching to process 28382 thread 0x1f03]
+0x0007a160 in GC_clear_stack_inner (arg=0x2ddf60 "", limit=3221225072) at misc.c:
+285     {
+(gdb) bt
+#0  0x0007a160 in GC_clear_stack_inner (arg=0x2ddf60 "", limit=3221225072) at 
+#2219 0x0007a190 in GC_clear_stack_inner (arg=0x2ddf60 "", limit=3221225072) at 
+#2220 0x00011428 in mono_object_allocate (size=84) at object.c:1313
+#2221 0x00011d58 in mono_string_new_size (domain=0x2ddf60, len=35) at 
+#2222 0x00011c9c in mono_string_new_utf16 (domain=0x2ddf60, text=0x23, 
+len=25170288) at object.c:1713
+#2223 0x00011e74 in mono_string_new (domain=0x2d2f00, text=0x115f3d0 "") at 
+#2224 0x00029fcc in ves_icall_System_AppDomainSetup_InitAppDomainSetup 
+(setup=0xa1d00) at appdomain.c:231
+#2225 0x000110c4 in mono_runtime_exec_main (method=0x115f030, 
+args=0x2d1ad0, exc=0xf0401dc0) at object.c:1189
+#2226 0x0000d45c in ves_exec (domain=0x2ddf60, assembly=0xbffffe70, argc=1, 
+argv=0xbffffc94) at interp.c:4890
+#2227 0x0001ec94 in start_wrapper (data=0x112abb0) at threads.c:230
+#2228 0x0006d2bc in timed_thread_start_routine (args=0x112abc0) at timed-
+#2229 0x900247e8 in _pthread_body ()
+the ellipsis is there because that line repeats 2219 times.
+------- Additional Comments From rshade@dvsconsulting.com  2003-12-02 13:53 -------
+According to some of the comments on the commits here:
+The gc is fails due to the threads on BSD.  There are some patches there that 
+attempting to fix it by using different signals to control the threads, but it looks like 
+that didn't work out.
+------- Additional Comments From lupus@ximian.com  2004-01-23 16:21 -------
+The gc6.3alpha4 release works for me on MacOSX: compile and install it
+separately and use ./configure --with-gc=boehm until we integrate it
+in mono. The release is available at: