[Mono-bugs] [Bug 53125][Wis] New - XmlSchemaImporter and/or XmlCodeExporter hangs with redefined components

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Tue, 20 Jan 2004 12:00:21 -0500 (EST)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by atsushi@ximian.com.


--- shadow/53125	2004-01-20 12:00:21.000000000 -0500
+++ shadow/53125.tmp.20841	2004-01-20 12:00:21.000000000 -0500
@@ -0,0 +1,62 @@
+Bug#: 53125
+Product: Mono/Class Libraries
+Version: unspecified
+OS Details: 
+Status: NEW   
+Priority: Wishlist
+Component: Sys.XML
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: atsushi@ximian.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: XmlSchemaImporter and/or XmlCodeExporter hangs with redefined components
+When we use schemas with redefinition as input to XmlSchemaImporter and 
+try to output using XmlCodeExporter, it hangs.
+1) Compile attached xsloop.cs to .exe and try "mono xsloop.exe a.xsd", or
+2) simply try "xsd a.xsd" (xsd.exe, which uses these features)
+Actual Results:
+$ mono xsloop.exe
+(Here the runtime silently hangs)
+$ xsd a.xsd
+Fatal stack overflow error.
+(Note: I ran it on cygwin. It means that this message comes from MS.NET 
+Runtime. When I tried "mono /my/path/to/xsd.exe", it also hanged silently.)
+Expected Results:
+I wonder it is the expected result, but MS System.Xml says:
+$ mono xsloop.exe
+Unhandled Exception: System.NotSupportedException: Cannot import schema 
+for type 'red' from namespace ''. Redefine not supported.
+   at System.Xml.Serialization.XmlSchemaImporter.ImportType(XmlSchemaType 
+type, String typeNs, String identifier, Type desiredMappingType, Type 
+[stack trace continues...]
+How often does this happen? 
+always with redefinition.
+Additional Information:
+I wrote another small test tool for W3C test suite:
+This source contains at which schema MS.NET hangs (yes, they hangs despite 
+of the exception above...) and Mono hangs.