[Mono-bugs] [Bug 60576][Maj] Changed - Bad interaction - Mono, Gentoo (nptl) & Muine

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Thu, 12 Aug 2004 23:49:44 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by latexer@gentoo.org.


--- shadow/60576	2004-08-12 23:45:23.000000000 -0400
+++ shadow/60576.tmp.24738	2004-08-12 23:49:44.000000000 -0400
@@ -450,6 +450,27 @@
 ------- Additional Comments From latexer@gentoo.org  2004-08-12 23:45 -------
 Created an attachment (id=9062)
 Simple test for libgc
+------- Additional Comments From latexer@gentoo.org  2004-08-12 23:49 -------
+The test i just posted seems to display the bug in libgc. If i run
+that program with a glibc with linuxthreads, i get lots of threads
+spawn, who continue to call lots of GC_MALLOCs each time they are spawn.
+However, if i run the same test program with a pure NPTL glibc, after
+about 200 or so threads (i'll have to test to get the exact number),
+the  "GC_ALLOC in thread!" messages disappear, and the only printed
+text is 
+250 threads
+251 threads
+252 threads
+etc, ad infinitum. I'm assuming that if the same type of thing was
+happening with mono, then the hangs everyone is seeing would be the
+result of this. hitting ^c and trying to get a "t a a bt" for this
+degenerate case always shows just one thread, with two lines with no
+symbols. I can try to get those symbols if it would help.