[Mono-bugs] [Bug 54813][Cri] Changed - mcs 0.31 crashes mono in metadata.c

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Wed, 14 Apr 2004 17:31:38 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by diltonm@mccomsoft.com.


--- shadow/54813	2004-04-14 03:08:18.000000000 -0400
+++ shadow/54813.tmp.16708	2004-04-14 17:31:38.000000000 -0400
@@ -508,6 +508,80 @@
 Mono JIT compiler version 0.31.99, (C) 2002-2004 Novell, Inc and
 Contributors. www.go-mono.com
 	TLS:           NPTL
 	GC:            Included Boehm (with typed GC)
 	SIGSEGV      : altstack
 	Globalization: ICU
+------- Additional Comments From diltonm@McCOMSoft.com  2004-04-14 17:31 -------
+> This is taken very seriously.
+> How did you install Mono? Did you build on your own, or are you 
+using an RPM?
+Most of the time I build and install from source but I've tried from 
+RPMs on one machine. I've duplicated this bug on several machines 
+all running the default Fedora 1 Core as well as Windows XP.
+I've tried the posted version on www.go-mono.com and CVS snapshots.
+It fails with exactly the same error on Windows XP and Fedora 1 Core 
+and has been since I posted the bug originally.
+It WAS working in 0.29 for sure, and even 0.28 IIRC.
+> Have you been using the same setup since the time when you first
+reported this bug? You may very well have stale files on your 
+If you read through the history you will see that I've duplicated 
+this bug on several machines of which, well, several were plain 
+vanilla, no prior hint of Mono. I will detail for you the procedure 
+I follow rigidly:
+On Fedora - I download the tar ball, read README and INSTALL, follow 
+the instructions, try to compile the sample code and then the error 
+that I've been reporting pops up.
+On Windows - I uninstall Mono from Add/Remove programs, download and 
+install the latest then try my test program and get exactly the same 
+> As for the information Miguel mentioned, it's specifically:
+On Fedora here is my printout:
+[xxxxx@xxxxxxx 30crash]# mono --version
+Mono JIT compiler version 0.31, (C) 2002-2004 Novell, Inc and 
+Contributors. www.go-mono.com
+        TLS:           NPTL
+        GC:            Included Boehm (with typed GC)
+        Globalization: none
+[xxxxx@xxxxxxx 30crash]#
+On Windows XP:
+C:\>mono --version
+Mono JIT compiler version 0.31, (C) 2002-2004 Novell, Inc and 
+Contributors. www
+        TLS:           normal
+        GC:            System Boehm (no typed GC available)
+        Globalization: ICU
+Yes the version seems to be slightly different and no I'm not going 
+to try the latest CVS (again) until someone there does what all we 
+software engineers do to close bugs properly and that is prove there 
+that you can delete Utils.dll and rebuild it then Client.cs and the 
+bug does not happen and do this on Fedora 1 (no updates) and Windows 
+XP (all updates) and do it sucessfully (deleting Utils.dll each 
+time) for several times in a row.
+This is a work blocking, compiler crash bug gentlemen, one that has 
+slipped through the past several releases even though your team was 
+made aware of it by me.