[Mono-bugs] [Bug 48376][Cri] Changed - mcs TypeInitializationException problem introduced in .26

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Tue, 16 Sep 2003 11:17:17 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by dgl@softec.st.


--- shadow/48376	2003-09-16 04:19:35.000000000 -0400
+++ shadow/48376.tmp.23005	2003-09-16 11:17:17.000000000 -0400
@@ -109,6 +109,28 @@
 related to the usage of DateTime:get_Now(). If you compile with
 another mcs (or event csc), using the DateTime:get_Now() under the
 0.26 runtime shows the same error. So, this seems runtime related.
 I have also reproduce it under Win2000 Server SP4. It does not happen
 under Windows XP.
+------- Additional Comments From dgl@softec.st  2003-09-16 11:17 -------
+Varga Zoltan wrote:
+I can reproduce this on my Win2K machine with a recent snapshot.
+This bug may only affect people in certain timezones. Here is a small
+using System;
+class Hello {
+        public static void Main (String[] args) {
+                TimeZone.CurrentTimeZone.GetDaylightChanges(2003);
+        }
+It also looks like to be a runtime problem. If I run this using
+./mono.exe hello.exe it fails. But when I run it using --trace, it runs.