[Mono-bugs] [Bug 47672][Maj] Changed - Thread.SetData throws ArgumentException only with Mono

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Wed, 1 Oct 2003 11:05:54 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by cmars@ziplip.com.


--- shadow/47672	2003-10-01 10:59:47.000000000 -0400
+++ shadow/47672.tmp.2213	2003-10-01 11:05:54.000000000 -0400
@@ -93,6 +93,23 @@
 ------- Additional Comments From cmars@ziplip.com  2003-10-01 10:59 -------
 Created an attachment (id=5479)
 Bamboo.Prevalence app that demonstrates the error.
+------- Additional Comments From cmars@ziplip.com  2003-10-01 11:05 -------
+Tried the patch on mcs-0.26 with no effect...  I patched a clean
+mcs-0.26, did a 'make' under Win32, and copied all the dlls to Mono's
+lib subdirectory.  Still getting the same error.
+Unf. I do not have ready access to a Linux box to test with, we are
+mainly a MS shop, but I would expect the same result.
+Please let me know if I need to do something different to apply this
+patch, I am still getting the exception.  I have attached a tarball
+(above) containing the MyFirstPrevalenceSystem executable (mfps.exe)
+and the Bamboo DLL so you can reproduce the error.  mfps.exe will
+throw the exception above but will run fine under MS.NET.
+Thank you for looking into this!