[Mono-bugs] [Bug 42658][Nor] Changed - Math.Round is unable to handle 0 as an argument

bugzilla-daemon@rocky.ximian.com bugzilla-daemon@rocky.ximian.com
Tue, 13 May 2003 17:11:50 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by bmaurer@users.sf.net.


--- shadow/42658	Fri May  9 22:15:52 2003
+++ shadow/42658.tmp.4888	Tue May 13 17:11:50 2003
@@ -1,23 +1,22 @@
 Bug#: 42658
-Product: Mono/Class Libraries
+Product: Mono/Runtime
 Version: unspecified
 OS: unknown
 OS Details: gentoo
 Status: NEW   
 Severity: Unknown
-Priority: Wishlist
-Component: CORLIB
+Priority: Normal
+Component: misc
 AssignedTo: mono-bugs@ximian.com                            
 ReportedBy: lda@lupa.pl               
 QAContact: mono-bugs@ximian.com
 TargetMilestone: ---
-Summary: Bug in Math.Round
+Summary: Math.Round is unable to handle 0 as an argument
 Description of Problem:
 Bug in Math.Round in mono 0.24
 Steps to reproduce the problem:
@@ -61,6 +60,21 @@
 or just
 Console.WriteLine (Math.Round((double) (100/l*p),2));
 the program will work fine (printing '0')
+------- Additional Comments From bmaurer@users.sf.net  2003-05-13 17:11 -------
+I had someone compile the sample lda sent in on csc and send it to me.
+Mono gave the same error -- so not an mcs bug.
+I tried running the binaries (both the mcs and csc one) on both mint
+and oldmono, and they both worked as expected! So this looks like a
+runtime but.
+I have made the testcase simplier:
+class Bug {
+    static void Main () {
+        System.Console.WriteLine (System.Math.Round (0));
+    }