[Mono-bugs] [Bug 45463][Wis] Changed - WebResponse returning NULL half-way through stream sometimes

bugzilla-daemon@rocky.ximian.com bugzilla-daemon@rocky.ximian.com
Sat, 19 Jul 2003 12:58:03 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by miguel@ximian.com.


--- shadow/45463	Fri Jun 27 11:17:21 2003
+++ shadow/45463.tmp.31141	Sat Jul 19 12:58:03 2003
@@ -78,6 +78,27 @@
 I've tried this both at work and at home, with the same results.  I
 also tried it on a friend's (different) network at his house; same
 ------- Additional Comments From bmaurer@users.sf.net  2003-06-27 11:17 -------
 *** Bug 45536 has been marked as a duplicate of this bug. ***
+------- Additional Comments From miguel@ximian.com  2003-07-19 12:58 -------
+The data above is in fact incorrect, the chunked reply is sending
+chunks which are bigger than they claim to be, so parsing the next
+chunk size fails. 
+I can not get chunked output from my ISP when talking to Google
+myself, so maybe what is going on is that there is a proxy in the
+middle that is sending this incorrect chunks?
+I have no explanation about how mozilla works, and it would be great
+if you could post a etherreal stream from this conversation (just
+google and run ethereal, and use the "Follow TCP Stream" feature).
+Then lets compare this traffic with the Mono Http runtime, and see
+where we are deviating.
+Nat, you are the only one that can help here, as you seem to be the
+one behind the proxy.