[Mono-bugs] [Bug 45036][Wis] Changed - Array.BinarySearch starts at incorrect location.

bugzilla-daemon@rocky.ximian.com bugzilla-daemon@rocky.ximian.com
Mon, 4 Aug 2003 16:57:51 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by duncan@ximian.com.


--- shadow/45036	Mon Aug  4 16:48:22 2003
+++ shadow/45036.tmp.7427	Mon Aug  4 16:57:51 2003
@@ -63,6 +63,23 @@
 added to the source that explains why we need that same behaviour.
 ------- Additional Comments From duncan@ximian.com  2003-08-04 16:48 -------
 Created an attachment (id=5054)
 Cleaned up patch
+------- Additional Comments From duncan@ximian.com  2003-08-04 16:57 -------
+Okay, I cleaned up Tum's patch (removing the section on FastCopy and
+CreateInstanceImpl and s/ArgumentException/ArgumentNullException) and
+attached it above.
+I tried to write unit tests for this patch, but I don't know how to
+trigger the bug.
+I ran all the BinarySearch-related tests from the Rotor testsuite, but
+all of them seem to run without any problems. The tests I ran are:
+* co3757binarysearch_oo.cs
+* co3758binarysearch_oiio.cs
+* co3759binarysearch_ooi.cs
+* co3760binarysearch_oiioi.cs
+* co3777aslist.cs