[Mono-bugs] [Bug 29658][Nor] New - "Array index is out of range" when program is run

bugzilla-daemon@rocky.ximian.com bugzilla-daemon@rocky.ximian.com
29 Aug 2002 22:08:03 -0000

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by andy_strain@softhome.net.


--- shadow/29658	Thu Aug 29 18:08:02 2002
+++ shadow/29658.tmp.3627	Thu Aug 29 18:08:02 2002
@@ -0,0 +1,83 @@
+Bug#: 29658
+Product: Mono/Class Libraries
+Version: unspecified
+OS: Red Hat 7.3
+OS Details: 
+Status: NEW   
+Priority: Normal
+Component: System
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: andy_strain@softhome.net               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: "Array index is out of range" when program is run
+Description of Problem:
+When running the program TCPechodAsync.exe using mono or mint, it throws an
+"Array index is out of range" System.IndexOutOfRangeException exception.
+This does not happen when the same proram is run under MS Windows with the
+.NET Framework installed.
+I can attach the TCPechodAsync.exe if you want, however, you can get the
+source code directly from http://www.ddj.com/ftp/2002/2002_09/tcpecho.txt
+and compile it with mcs. You want Listing One, which is 252 lines long.
+Other than the exception, the program does seem to work, though.
+Steps to reproduce the problem:
+1. mono TCPechodAsync.exe
+2. mint TCPechodAsync.exe
+Actual Results:
+For mono:
+Unhandled Exception: System.IndexOutOfRangeException: Array index is out of
+in <0x000c8> 00 System.Collections.ArrayList:Add (object)
+in <0x0018c> 00 System.Threading.ThreadPool:CheckIfStartThread ()
+in <0x0001f> 00 System.Threading.ThreadPool:MonitorThread ()
+in <0x00057> 01 System.MulticastDelegate:invoke_void ()
+For mint:
+Array index is out of range
+#0: 0x00051 stelem.ref in System.Collections.ArrayList::Add ([0x80faa50] )
+#1: 0x00075 callvirt   in System.Threading.ThreadPool::CheckIfStartThread ()
+#2: 0x00001 call       in System.Threading.ThreadPool::AddItem ([0x40c49f70] )
+#3: 0x0001b call       in
+System.Threading.ThreadPool::QueueUserWorkItemInternal ([0x80f38a0]
+[0x80f81b0] )
+#4: 0x00007 callvirt   in System.Threading.ThreadPool::QueueUserWorkItem
+([0x80f38a0] [0x80f81b0] )
+#5: 0x00096 call       in .TCPechodAsync::finishAccept ([0x81ca960] )
+#6: 0x00000            in System.AsyncCallback::Invoke ([0x81ca960] )
+#7: 0x00022 callvirt   in .Worker::End ()
+#8: 0x0001f call       in .Worker::Accept ()
+#9: 0x00000            in System.Threading.ThreadStart::Invoke ()
+** Message:
+returning 10038
+Expected Results:
+Nothing is suppose to be displayed at all until a user `telnet localhost
+2000` then something like:
+Connection from localhost.localdomain ( port 36449
+should appear.
+How often does this happen? 
+Every single time I run TCPechodAsync.exe.
+Additional Information:
+I've tried this both on mono-0.15-1.i386.rpm and