[Mono-bugs] [Bug 29580][Nor] New - assebmly lookups are inconsistent

bugzilla-daemon@rocky.ximian.com bugzilla-daemon@rocky.ximian.com
28 Aug 2002 17:58:17 -0000

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by joe@ximian.com.


--- shadow/29580	Wed Aug 28 13:58:17 2002
+++ shadow/29580.tmp.9833	Wed Aug 28 13:58:17 2002
@@ -0,0 +1,42 @@
+Bug#: 29580
+Product: Mono/MCS
+Version: unspecified
+OS: other
+OS Details: 
+Status: NEW   
+Priority: Normal
+Component: Misc
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: joe@ximian.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: assebmly lookups are inconsistent
+I ran into a problem compiling mphoto today.  The makefile was laid out
+like so:
+ASSEMBLIES=-r glib-sharp.dll -r pango-sharp.dll -r atk-sharp.dll -r
+gdk-sharp.dll -r gtk-sharp.dll -r gnome-sharp.dll -r System.Drawing
+Since my gtk# assemblies are in /opt/mono/lib, mcs couldn't find them.  I
+set MONO_PATH, expecting them to be picked up, but they weren't.  When I
+removed the ".dll" suffix from all of the gtk# assemblies, it then worked
+with MONO_PATH.
+So then I experimented by adding ".dll" to the System.Drawing reference,
+which is in /usr/lib.  It worked.
+The bug is that when specifying an assembly explicitly (that is, with a
+.dll extension) but with a relative path, it should ONLY look in the path
+relative to the current working directory, NOT in /usr/lib.  So, basically,
+"-r System.Drawing.dll" shouldn't work, unless I'm building from /usr/lib.  
+In these cases, mcs should also be explicit about where it looked for the
+assembly.  That is, if I build in /cvs/mono and do the "-r
+System.Drawing.dll" above, it should say something like "error CS0006:
+Cannot find assembly `/cvs/mono/System.Drawing.dll'" so as to clarify where
+exactly it looked.