[Mono-aspnet-list] Problem With Mono + Apache2 with Mod-Mono

Marcos Junior junalmeida at gmail.com
Mon Mar 24 17:11:34 UTC 2014

I have just created a new machine with ubuntu LTS (precise).

Now apache version is:
junalmeida at dev4:~$ apache2 -v
Server version: Apache/2.2.22 (Ubuntu)

Mono version is:
junalmeida at dev4:~$ mono --version
Mono JIT compiler version 3.2.1 (Debian 3.2.1+dfsg-1~pre2)

But mod-mono-server is still 2.10, i couldn't find a deb package with a
newer version. The mod_mono git source (https://github.com/mono/xsp) does
not have any branch for 3.2.x.
junalmeida at dev4:~$ mod-mono-server4 --version

Still no luck with this VM. If I change bin or config, apache hangs untill
I also set apache log to DEBUG, but now with these configs I no longer get
the MaxRequestWorkers error.

I have also another machine with a default ubuntu server iso with the same
versions I listed above and the server works good. I can change binaries or
config, mono recompiles and goes live again.

The difference is that this dev4 problematic machine is an ubuntu x64 at
amazon AWS EC2.

Att, Marcos Almeida Junior.

On Mon, Mar 24, 2014 at 10:01 AM, David Schmitt <david at dasz.at> wrote:

> Re,
> On 2014-03-24 13:35, Marcos Junior wrote:
>> Hello david. Yes, I tried to raise MaxRequestWorkers. No luck.
>> Im using the latest 3.x mono available on ppa monoxide. Should I try
>> to revert to the old 2.x ubuntu package?
> Quoting from your first message:
>  # mod-mono-server4 --version
>> mod-mono-server4.exe
> You're still using 2.10. Or you have a mismatched installation, which is
> probably even worse.
> Regards, David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-aspnet-list/attachments/20140324/91fa5166/attachment.html>

More information about the Mono-aspnet-list mailing list