[Mono-aspnet-list] help with asp.net on raspberry pi: private libraries issue

danielem cyberpumiz at tiscali.it
Mon Mar 3 16:25:45 UTC 2014

Hi all,

I am writing because I really cannot solve a problem with the private
libraries in an asp.net application.

I am working on a Raspberry pi.

It should be as easy as:
"To reference private libraries, just place the libraries in the "bin"
directory below your application and they will be referenced automatically
for you:"

Unfortunately this was true when I successfully tried to run a simple c#
project (and everything worked as expected).

Instead, when I try to run an .aspx file with the below procedure:
"The easiest way to start XSP is to run it from within the root directory of
your application. It will serve requests on port 8080. Place additional
assemblies in the bin directory. Other XSP options can be set on the command
line, such as the application directory and the port to listen on."

I get the exception


the application stops when I tried to import the shared object libbcm2835.so 

created in the following way:
tar -zxf bcm2835-1.3.tar.gz
cd bcm2835-1.3/src
make libbcm2835.a
cc -shared bcm2835.o -o libbcm2835.so

from the below library

The program breaks when I try to use the function:


defined as:
[DllImport("libbcm2835.so", EntryPoint = "bcm2835_init")]
static extern int bcm2835_init();

The exact same program, instead, works perfectly when it is in C#.

Could you please help me to find out how to make it work?

Thank you very much in advance for you time!

View this message in context: http://mono.1490590.n4.nabble.com/help-with-asp-net-on-raspberry-pi-private-libraries-issue-tp4662094.html
Sent from the Mono - ASP.NET mailing list archive at Nabble.com.

More information about the Mono-aspnet-list mailing list