[Mono-aspnet-list] XSP crash on config file with ASP.Net MVC 3 project

James Rhodes jrhodes at redpointsoftware.com.au
Wed Oct 9 21:27:05 UTC 2013

As far as I can tell this is some sort of issue when it's running as the
.NET 4.5 framework.  I believe I encountered this issue and solved it by
changing the application to use .NET 4.0 instead.

It's something to do with the System.Configuration.dll being the wrong
version for the framework (wrong symlink or something), which causes XSP to
die when trying to read configuration.

Regards, James Rhodes.
Redpoint Software


On 10 October 2013 00:45, Arnaud M <hokkos at gmail.com> wrote:

> Hi,
> so I compiled XSP with tag 3.0.11 from git, installed it in /opt/mono
> tested it with monodevelop to have the same error, and also tried at the
> command line with
> xsp4 --port 8077 -address --verbose
> I have the exact same error. :(
> Thanks.
> 2013/10/9 chris.schamper <chris.schamper at gmail.com>
> Greetings,
>> I hit the exact same error. The issue is the version of XSP. You want to
>> get
>> tag 3.0.11 from the git repo:
>> Github.com/mono/xsp
>> Compile 3.0.11. There is no need to run the make install step as it can be
>> run locally. There are two XSP binaries, xsp2 and xsp4. You want to use
>> xsp4
>> for a .NET 4.0/4.5 solution.
>> Cheers!
> _______________________________________________
> Mono-aspnet-list mailing list
> Mono-aspnet-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-aspnet-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-aspnet-list/attachments/20131010/d863f0f8/attachment.html>

More information about the Mono-aspnet-list mailing list