[Mono-aspnet-list] Mono + Nginx + Open BSD

Gee g.plumb at gmail.com
Tue May 7 18:56:31 UTC 2013


I am having trouble getting Mono to work with nginx.  I installed my OS
(OpenBSD 5.3) and set up ports.  I built mono, mono-xsp and nginx - all
without incident.  All three appear to be working OK, but not in

I am trying to run a *very* simple MVC3 app - it is literally a hello world
controller (no fancy code whatsoever) - but I keep getting a 502 (Bad
gateway).  In the log, I see the following:

[crit] 31764#0: *1 connect() to unix:/tmp/fastcgi.socket failed (2: No such
file or directory) while connecting to upstream,

The frustrating thing here is that /tmp/fastcgi.socket does actually exist.
 I tried 'touch' and making sure 'www' and 'wheel' have the appropriate
permissions (which they do).  The result of 'ls -la /tmp/fastcgi.socket'
revealed nothing awry.  I tried using a different path (such as
'/home/socket' and '/home/fastcgi.socket'), but all to no avail.

Does anyone have any ideas/hints?  Could this be a bug in the port?

To try and save time, here is my config:

worker_processes  1;

events {
    worker_connections  1024;

http {
    include       mime.types;
    default_type  application/octet-stream;

    server {
        listen 80;
        access_log   /home/www/nginx.log;
        error_log    /home/www/errors.log;

        # root /home/www/test;
        # index index.html index.htm index.aspx default.aspx;

        location ^~ /Scripts/ { }
        location ^~ /Content/ { }

        location / {
            root /home/www/test;
            # fastcgi_index /Home/Index;

            fastcgi_pass   unix:/tmp/fastcgi.socket;
            # include        fastcgi_params;
            include /etc/nginx/fastcgi_params;

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-aspnet-list/attachments/20130507/653df3b8/attachment.html>

More information about the Mono-aspnet-list mailing list