[Mono-aspnet-list] MVC4 and mod_mono

eSPiYa vdolosa at gmail.com
Fri Feb 15 15:30:47 UTC 2013

Just started trying to learn ASP.NET MVC4 and trying to deploy it on my
Ubuntu 12.04 server.

I can build and deploy basic ASP.NET web-apps, even tried using Razor 2.0 on
my server. But whenever I try to deploy my MVC4 app, it will just show the
root directory of this web app and can't load my HomeController. Developed
using MSVS2012, and written from scratch. I always exclude
'Microsoft.Web.Infrastructure' from the deployment because of Mono has its
own implementation of this library. 

I even tried to run it on the same server using XSP4 and it works, it just
fails on mod_mono. I even tried to restart the whole apache2 server,
mono-xsp4, and mod-mono-server4(through the control panel), but it does
nothing. Tried to look at the error logs of apache2 but there are no error
message there aside from the 'No application found for /Home', which is
generated whenever I tried to access the default

View this message in context: http://mono.1490590.n4.nabble.com/MVC4-and-mod-mono-tp4658598.html
Sent from the Mono - ASP.NET mailing list archive at Nabble.com.

More information about the Mono-aspnet-list mailing list