[Mono-aspnet-list] XSP4 and Monodevelop on Win7 x64

Jon Sutherland jon.sutherland at gmail.com
Tue Jun 12 14:39:12 UTC 2012

Hmm I just realized that it's fast-cgi-mono-server4 that works fine...  I
get the same errors about XSPWebSource ctor and hanging indefinitely when
running XSP4 from the command line

On Tue, Jun 12, 2012 at 11:58 AM, Jon Sutherland
<jon.sutherland at gmail.com>wrote:

> I've been trying to solve this issue the last few days.  It seems that
> whenever I run my ASP.NET MVC3 app from MonoDevelop is just hangs
> indefinitely.  If I wait 10 or 20 minutes it's still waiting for a
> response.  The whole time the CPU is not doing anything.  This happens when
> running without debugging, when I try to run with debugging I get a strange
> error attached below.
> However when I run xsp4 from the command line with the same parameters
> things run fine.  I am wondering why MonoDevelop doesn't work, I tried
> deleting it's older xsp2.exe and xsp4.exe in the MonoDevelop bin dir but
> that didn't help.  I've read through a lot of posts but I can't find anyone
> describing the same issue.
> A few more details, My project references the Mono.WebServer2.dll from the
> mono libs.  I feel like this may have something to do with the issue since
> the web app runs fine without Mono.WebServer2.dll from the command line but
> I get System.MissingMethodException: Method not found:
> 'Mono.WebServer.XSPWebSource..ctor' from MonoDevelop without the WebServer2
> dll.  I am using Mono 2.11.1 and MonoDevelop  If anyone has any
> suggestions that would be great.
> The error I get when debugging:
> Handling exception type TypeLoadExceptionMessage is Could not load type
> 'System.Security.SecurityRulesAttribute' from assembly 'System.Web'.
> IsTerminating is set to True
> System.TypeLoadException: Could not load type
> 'System.Security.SecurityRulesAttribute' from assembly 'System.Web'.
> Server stack trace:
>   at System.AppDomain.DoCallBack (System.CrossAppDomainDelegate
> callBackDelegate) [0x00000] in <filename unknown>:0
>   at (wrapper remoting-invoke-with-check) System.AppDomain:DoCallBack
> (System.CrossAppDomainDelegate)
>   at (wrapper xdomain-dispatch) System.AppDomain:DoCallBack
> (object,byte[]&,byte[]&)
> Exception rethrown at [0]:
>   at (wrapper xdomain-invoke) System.AppDomain:DoCallBack
> (System.CrossAppDomainDelegate)
>   at (wrapper remoting-invoke-with-check) System.AppDomain:DoCallBack
> (System.CrossAppDomainDelegate)
>   at System.Web.Hosting.ApplicationHost.CreateApplicationHost (System.Type
> hostType, System.String virtualDir, System.String physicalDir) [0x00000] in
> <filename unknown>:0
>   at Mono.WebServer.VPathToHost.CreateHost
> (Mono.WebServer.ApplicationServer server, Mono.WebServer.WebSource
> webSource) [0x00000] in <filename unknown>:0
>   at Mono.WebServer.XSP.Server.RealMain (System.String[] args, Boolean
> root, IApplicationHost ext_apphost, Boolean quiet) [0x00000] in <filename
> unknown>:0
>   at Mono.WebServer.XSP.Server.Main (System.String[] args) [0x00000] in
> <filename unknown>:0
> Missing method .ctor in assembly
> C:\Projects\Brown\Brown.Inspections\Bin\System.Web.dll, type
> System.Security.SecurityRulesAttribute
> Can't find custom attr constructor image:
> C:\Projects\Brown\Brown.Inspections\Bin\System.Web.dll mtoken: 0x0a000ac0
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-aspnet-list/attachments/20120612/9534cc15/attachment-0001.html>

More information about the Mono-aspnet-list mailing list