[Mono-aspnet-list] Help on installing XSP

yizhew yizhew at yahoo.com.cn
Wed Sep 7 10:46:14 EDT 2011

I got latest version of mono-2.10.5 and xsp-2.10.2, my OS environment is
CentOS 6. After successfully installing mono and proceeding to install xsp I
encountered a wired problem, when I tried to do ./configure
--prefix=/usr/local/mono/2.10.5/xsp under xsp's source code folder, I got an
error message 
*checking for Mono 2.0 GAC for System.Core.dll... not found
configure: error: missing required Mono 2.0 assembly: System.Core.dll*
. I opened configure file and tried to figure out the cause, I thought the
error source should be 
*if test \
			-e "$($PKG_CONFIG --variable=libdir mono)/mono/2.0/$asm.dll" -o \
			-e "$($PKG_CONFIG --variable=prefix mono)/lib/mono/2.0/$asm.dll"; \
			then \
			{ $as_echo "$as_me:$LINENO: result: found" >&5
$as_echo "found" >&6; }
			{ $as_echo "$as_me:$LINENO: result: not found" >&5
$as_echo "not found" >&6; }
			{ { $as_echo "$as_me:$LINENO: error: missing required Mono 2.0 assembly:
$asm.dll" >&5
$as_echo "$as_me: error: missing required Mono 2.0 assembly: $asm.dll" >&2;}
   { (exit 1); exit 1; }; }

when I tried to expand the command one by one $PKG_CONFIG --variable=libdir
mono => /usr/local/mono/2.10.5/lib/mono/2.0 and I could find the file

Can anyone help me on the problem?

View this message in context: http://mono.1490590.n4.nabble.com/Help-on-installing-XSP-tp3796265p3796265.html
Sent from the Mono - ASP.NET mailing list archive at Nabble.com.

More information about the Mono-aspnet-list mailing list