[Mono-aspnet-list] Cherokee skips fastcgi-mono-server4 running asp.net MVC 4.0

Aarón aamarber at karira.es
Thu Mar 24 05:08:59 EDT 2011

My problem is that when I run an ASP.NET MVC page with cherokee and 
mono, cherokee skips the fastcgi-mono-server and says 404 not found, 
instead of returning the data from mono-server.

I followed this tutorial of cherokee to run asp.net under 

And I launch the fastcgi-mono-server4 with the next command from the 

sudo fastcgi-mono-server4 
/socket=tcp: /stopable=TRUE 

When I put this in the browser: localhost/myapplication it says HTTP 500 
The value for the name controller must be a non-empty string; that's OK, 
because myapplication is an api.

But if I put localhost/myapplication/websites/getwebsites it says the 
404 error.

I also tried with this example of msdn: 

It happens something different, the index page it's shown but when I 
click a link, it says 404 error.

What can I do?? Thanks a lot!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-aspnet-list/attachments/20110324/dc734ca4/attachment-0001.html 

More information about the Mono-aspnet-list mailing list