[Mono-aspnet-list] Webmethod invoke fails with lighttpd and xsp

Poiros Poiros at hotmail.com
Mon Nov 8 14:00:43 EST 2010

I am currently trying to run a webservice with lighttpd. The webservice seems
to work fine, until i try to invoke a webmethod, where i get the following
error message:

404 - Not Found
<?xml version="1.0" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
xmlns="http://www.w3.org/1999/xhtml" xml:lang="en"
lang="en"><head><title>Error 404</title><style type="text/css">body
.7em;color:black;background-color: white}
p {font-family:"Verdana","DejaVu
Sans",sans-serif;font-weight:normal;color:black;margin-top: -5px}
b {font-family:"Verdana","DejaVu
Sans",sans-serif;font-weight:bold;color:black;margin-top: -5px}
h1 { font-family:"Verdana","DejaVu
Sans",sans-serif;font-weight:normal;font-size:18pt;color:red }
h2 { font-family:"Verdana","DejaVu
Sans",sans-serif;font-weight:normal;font-size:14pt;color:maroon }
pre,code {font-family:"Lucida Console","DejaVu Sans
Mono",monospace;font-size: 0.9em,white-space: pre-line}
div.bodyText {font-family: "Verdana","DejaVu Sans",sans-serif}
table.sampleCode  100%; background-color: #ffffcc; 
.errorText  red; font-weight: bold
.marker {font-weight: bold; color: black;text-decoration: none;}
.version  gray;
.error {margin-bottom: 10px;}
.expandable { text-decoration:underline; font-weight:bold; color:navy;
cursor:pointer; }</style></head><body><h1>Server Error in '/'
Application</h1><hr style="color: silver"/><h2><em>The resource cannot be
<p><strong>Description: </strong>HTTP 404. The resource you are looking for
(or one of its dependencies) could have been removed, had its name changed,
or is temporarily unavailable.  Please review the following URL and make
sure that it is spelled correctly.</p>
<p><strong>Requested URL: </strong>/GimmeANumber</p>
<hr style="color: silver"/><strong>Version information: </strong> Mono
Runtime Version: <tt>2.8 (tarball Thu Oct  7 17:21:25 CEST 2010)</tt>;
ASP.NET Version: <tt>2.0.50727.1433</tt></body></html>

I tried to run the webservice under different setups, and I found out that
the webmethod works when i use the mono-fastcgi-server2 v.2.4.3-3 package.
Correct me if i'm wrong, but this package is directly associated with the
mono-xsp2-base package, which has the same version number. When i use a
newer version of these packages, it fails no matter what version of
mono-runtime i use (i used both mono 2.6.7 and mono 2.8). I also tried to
run it with mono-developp, and it works fine!

Does anyone know any possible issues with lighttpd/xsp running webservices?


View this message in context: http://mono.1490590.n4.nabble.com/Webmethod-invoke-fails-with-lighttpd-and-xsp-tp3032483p3032483.html
Sent from the Mono - ASP.NET mailing list archive at Nabble.com.

More information about the Mono-aspnet-list mailing list