[Mono-aspnet-list] Thread being aborted on xsp2 on FreeBSD trying to use ASP.NET MVC

Patrick Kristiansen patrick.kristiansen at gmail.com
Sun Jul 19 06:24:14 EDT 2009


I am trying to use ASP.NET MVC on mono (fastcgi-mono-server2, lighttpd
and FreeBSD). To test that ASP.NET worked, I created a simple .aspx
page with the following in it:

<%= DateTime.Now.ToString() %>

This works fine, and it seems that regular ASP.NET is working at

Next I followed these guidelines (for Visual Studio) with a fresh
ASP.NET MVC project:


When I try running an ASP.NET MVC application, from either xsp or
fastcgi-mono-server, I get the following error in my web browser
(trying to access

  Thread was being aborted

  Description: HTTP 500. Error processing request.

The stack trace shown is not consistent, the processing stops at
different places, but usually at

  System.Web.Mvc.WebFormViewEngine.FileExists( ... )

If I run the website using xsp (as opposed to fastcgi-mono-server), I
get the following stack trace when xsp exits upon a request from my

  Error: System.Net.Sockets.SocketException: Address already in use
    at System.Net.Sockets.Socket.Bind (System.Net.EndPoint local_end) [0x00000]
    at Mono.WebServer.XSPWebSource.CreateSocket () [0x00000]
    at Mono.WebServer.ApplicationServer.Start (Boolean bgThread) [0x00000]
    at Mono.WebServer.ApplicationServer.Start (Boolean bgThread,
System.Exception initialException) [0x00000]
    at (wrapper remoting-invoke-with-check)
Mono.WebServer.ApplicationServer:Start (bool,System.Exception)
    at Mono.WebServer.XSP.Server.RealMain (System.String[] args,
Boolean root, IApplicationHost ext_apphost, Boolean quiet) [0x00000]

I use the following command to start xsp:

  xsp2 --address --root /home/patrick/monotest/www \
    --applications '/:.'

I'm running FreeBSD 7.2, Mono and xsp

Can anybody help?

Thanks in advance,


More information about the Mono-aspnet-list mailing list