[Gtk-sharp-list] Help on getting Webkit Widget in Monodevelop?

Jacek Rużyczka stacheldraht at interia.pl
Thu Sep 12 19:52:33 UTC 2013

> Had installed MonoDevelop on Ubuntu Studio 13.04
> amd64, I then downloaded the webkit_sharp from Git, it built fine, the
> assemblies were there, the compile went ok, but like the above, i got
> the nasty Missing Dll Exception when running the application, plus
> wasnt sure just what and where I was supposed to add the WebView class
> to also. Following suit, I found that in
> the ./sources/webkit-sharp.dll.config and the
> webkit-sharp.dll.config.in the libraries were called "webkit-1.0.so.2"
> which was way off for me, mine were called "webkitgtk-1.0.so.0", so I
> had to make the appropriate changes.. possible it would have been
> better to do this in the configure.in, but i hate dealing with it so I
> just ran 'make clean' and then 'make' again in that directory, copied
> the webkit-sharp.dll over the faulty ones in my system, and BAM!!
> everything works! Words cannot tell how much I appreciate this post.
This is, in fact, the problem which now stops me from suing
webkit-sharp. On OpenSUSE 12.1 I had already encountered the library
name issue, but a simple symlink from webkit-1.0.so.2 to
webkitgtk-1.0.so.0 solved the problem, so I didn't even have to compile
anything from scratch.

After upgrading to OpenSUSE 12.3, the trouble came back. Symlinking
didn't help this time. Neither did copying the recent lib to the name
expected by webkit-sharp. I also tried out the sourcecode (plus adapting
webkit-sharp.dll.config and then webkit-sharp.dll.config.in), but the
whole lot keeps on throwing the nasty DllNotFoudException: webkit-1.0.

Do you have a useful hint for me? Thank you.

Kind regards
Jacek Rużyczka

More information about the Gtk-sharp-list mailing list