[Gtk-sharp-list] GTK# Installation issue - all dependent apps fail to load

ms_camps martyns.camplaw at gmail.com
Mon Feb 25 15:56:44 UTC 2013

I have posted this in the  Xamarin forums
without any luck so I hope it's OK to post here as I think this is more
likely to get results now after some investigation.
Initially this began as an issue with Xamarin Studio 2.0 failing to run and
logging the error: "*System.DllNotFoundException: Unable to load DLL
'libgtk-win32-2.0-0.dll': The specified procedure could not be found.
(Exception from HRESULT: 0x8007007F)*". But after trying to diagnose this
myself I have realised this is an issue with my Gtk# installtion. If I
install any other apps, such as Tomboy Notes, that depend on the library
they also fail to open. Also, if a create a new console app in Visual Studio
and add gtk-sharp.dll as a dependency the app, when run, immedietly throws
the same error.
I have tried install/uninstalll/reinstall numerous times, and the installer
doesn't seem to have any issues. 
I've loaded libgtk-win32-2.0-0.dll into DependencyWalker (a tool I
discovered from googling for this problem so I'm far from an expert in its
use) and it highlights GPSVC.DLL as a module that isn't found. GPSVC.DLL is
present in C:\Windows\System32 though not in SysWOW64 where it as a x86 lib
would be looking. But, as far as I can tell from googling the library
shouldn't be there so I'm guessing that's a red herring.
Does anyone have any ideas? I'm truly baffled.

View this message in context: http://mono.1490590.n4.nabble.com/GTK-Installation-issue-all-dependent-apps-fail-to-load-tp4658736.html
Sent from the Mono - Gtk# mailing list archive at Nabble.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/gtk-sharp-list/attachments/20130225/ca9920e4/attachment.html>

More information about the Gtk-sharp-list mailing list