[Gtk-sharp-list] GTK3 and EntryPointNotFoundException in gtksharp

Sergey Litvinov phoenixxua at gmail.com
Thu Dec 1 13:43:23 EST 2011

 Hello everyone,

I am developing some program, and I am trying to use gtksharp with gtk3. As
I saw from previous emails – source code from master should support gtk3.
And I am trying to build and use it with gtk 3. But I’ve found a problem.
I use gtk 3.2 libraries under Ubuntu\Windows 7. For Windows 7 I’ve
downloaded gtk3.2 from OpenSUSE build server and latest version of
gtk-sharp from master branch.

I found one strange thing in
https://github.com/mono/gtk-sharp/blob/master/glib/Thread.cs . For
g_thread_get_initialized it use external call to libgthread-2.0-0 library.
But in that library there is no such method and when I try to call
Gtk.Application.Init() - it fails with EntryPointNotFoundException. It
fails with the same error on both Windows and Ubuntu.  I investigated glib
source and gtk-sharp/glib history and found that such method exist in

The library name in Thread.cs file was changed at Jan 7 2011 in this commit -
I’ve locally updated library name in Thread.cs to libglib-2.0-0.dll, built
it again, and tried to call Gtk.Application.Init(). And seems it was
successful. I am newbie there and my question is – was it a mistake? If
yes, I can do a pull request to gtk-sharp git repo.

With Regards, Sergey Litvinov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/gtk-sharp-list/attachments/20111201/3389fcac/attachment-0001.html 

More information about the Gtk-sharp-list mailing list