[Gtk-sharp-list] Logical error in behavior when Treeview model's Selection.Mode = SelectionMode.Multiple

soy soylist at gmail.com
Wed Aug 18 16:14:15 EDT 2010

There seems to be an off by one bug/error in the way a Treeview behaves when
its Model's Selection.Mode is set to Multiple.

When I use the GetSelectedRows() method to get an array of TreePath, then
iterate over that array, it will never include the last row a user selected. 
I've been using the CursorChanged signal for my Treeview as the point at
which I use the GetSelectedRows() method.  I've tried other signals to see
if the results would be different, but none of them have worked either.  

Is this really a  bug, or am I going about this the wrong way?  I hope it's
not a bug..........
View this message in context: http://mono.1490590.n4.nabble.com/Logical-error-in-behavior-when-Treeview-model-s-Selection-Mode-SelectionMode-Multiple-tp2330345p2330345.html
Sent from the Mono - Gtk# mailing list archive at Nabble.com.

More information about the Gtk-sharp-list mailing list