[Gtk-sharp-list] Gtk-Sharp throws exception on Windows

Gonzalo Fernández horcas at bbs.frc.utn.edu.ar
Wed Oct 4 11:38:11 EDT 2006

Carlos J. Muentes escribió:
> Method not found exceptions usually occur when running a different
> (usually older) versions of a referenced assembly.  Try confirming that
> you are running the same versions of the gtk# libraries on both Linux
> and Windows.

I´m having a problem with GTK# versions too. Installed mono on 
windows and Slackware (the same versios) but my .exe dosn´t work on 
linux, the gtk# version seems to be (as I saw with the 
gacutils), and on windows is Why is that? Since I compiled on 
Windows (with the .NET framework), I get an exception on Linux 
(gtk-sharp assembly not found). They should install the same 
versions of each assembly.
I tried to install the gtk# packages on linux but get an error 
(I belive it was when run ./configure), the error says that I must 
install Mono.Cairo.dll. I don´t understand that, does it means that 
Mono.Cairo.dll should be in the GAC or a particular directory or some 
environment variable?

Gonzalo Fernández

 Laboratorio de Sistemas - UTN FRC
     Grupo de Desarrollo .NET
Email/MSN: horcas at bbs.frc.utn.edu.ar

>> -------- Original Message --------
>> Subject: [Gtk-sharp-list] Gtk-Sharp throws exception on Windows
>> From: Hongli Lai <h.lai at chello.nl>
>> Date: Wed, October 04, 2006 11:15 am
>> To: gtk-sharp-list at lists.ximian.com
>> I'm currently writing a Gtk-Sharp app using Mono on Linux. It's supposed 
>> to also work on Windows.
>> But when I run the program, it throws an exception:
>> Method not found: Void Gdk.Drawable.DrawPoints(Gdk.GC, Gdk.Point[]).:
>>     at FieldEditor.FieldView.RenderToDrawable(Field field, 
>> FieldSelection region, FieldSelection selection, UInt32 zoomLevel, 
>> Drawable drawable)
>>     at FieldEditor.FieldView.OnExposed(Object o, ExposeEventArgs args)
>>     at Gtk.Widget.ExposeEventSignalCallback(IntPtr arg0, IntPtr arg1, 
>> IntPtr gch)
>>     at Gtk.Application.gtk_main()
>>     at Gtk.Application.Run()
>>     at FieldEditor.MainClass.Main(String[] args)
>> This is weird. The program can create Gtk windows and widgets correctly, 
>> yet cannot call Gdk functions. Did I do something wrong or is this a bug 
>> in Gtk-Sharp?
>> Extra information:
>> - The program's source code is located at 
>> http://svn.sourceforge.net/viewvc/openkore/field-editor/trunk/
>> - A binary is available here: http://www.openkore.com/misc/FieldEditor.zip
>> - To use the program you need a random .fld file, available here: 
>> http://svn.sourceforge.net/viewvc/openkore/fieldpack/trunk/fields/
>> - I'm using .Net framework 2.0 and Gtk-Sharp 2.7.1-0.4
>> - The .exe was compiled as follows: mcs 
>> -pkg:gtk-sharp-2.0,glade-sharp-2.0 *.cs -out:bin/Release/FieldEditor.exe 
>> -target:winexe -optimize
>> _______________________________________________
>> Gtk-sharp-list maillist  -  Gtk-sharp-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/gtk-sharp-list
> _______________________________________________
> Gtk-sharp-list maillist  -  Gtk-sharp-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/gtk-sharp-list

More information about the Gtk-sharp-list mailing list