[Gtk-sharp-list] Glade and ToolBar

RUAUDEL Frédéric ruaudel@embl-grenoble.fr
Mon, 23 Aug 2004 09:12:45 +0200


   I confirmed that I had the same problem (any button created in a 
toolbar never appears in the final app) and I worked around it by 
creating the toolbar by hand but it would be great if it can be fixed. I 
also tried to use an older glade (V2.2 instead of V2.4 that was in my 
FC2) to avoid the new 2.4 widgets but I run with the same problems.

Best regards,


Olivier -Staz- Lê Thanh wrote:

>it seem there is a problem making a ToolBarButton work in glade.
>The bug is perfectly reproducible,  create a window in glade add it a
>toolbar and a toolbar button, connect the clicked signal, program the
>corresponding callback function. Compile, launch the program, click, and
>nothing happen.
>Is there a problem in my program or callback function (no error at
>compiling or at running and the .glade file seem to be fine since it
>work in pygtk) or is it a bug in gtk-sharp (didn't found anything in
>bugzilla and I'm using version 1.0)?
>Thanks for any help,