[Gtk-sharp-list] GTK# 0.11+ Windows Installer Released

Jonathan Pryor jonpryor@vt.edu
Mon, 27 Oct 2003 08:17:21 -0500

On Sun, 2003-10-26 at 19:05, jasper van putten wrote:
> It works fine under mono , but .net has problems finding the files. I have
> been trying to fix this by setting the $Path to the mono-0.28\lib directory
> but this didn't help. The  only way to get it running is by placing the program
> in the mono-0.28\lib. Does anybody know how this can be solved in a clean
> way.

This is by design.  For .NET. :-)

The Gtk# assemblies probably aren't "public" assemblies.  Meaning that
they likely don't have a strong name, haven't been signed, and aren't
located in the Global Assembly Cache.

Which means that they're "private" (non-shared) assemblies.  Which means
that they *must* be located in the same directory as the program.

So you have one of four choices:

  - Run your program under mono, which you've tried

  - Copy your program into mono-0.28\lib, which you've done

  - Copy the Gtk# DLLs into your programs directory

  - Wait (or help) for Gtk# to become strong-named, so it can be placed 
    in the GAC.  Last I heard, the hold-up with this was that we didn't
    want to deal with two separate build routines (one for Linux, one 
    for .NET), and Linux didn't have the functionality for signing 
    assemblies.  This is not longer entirely true, thanks to S├ębastien

    I have no idea when mono will have full support for signing 
    assemblies, though.

 - Jon