[Gtk-sharp-list] Glade# on .NET

Simon Guindon simon@nureality.ca
Wed, 9 Apr 2003 14:40:39 -0400

Hello all, I've been experimenting with GTK# on the win32 platform using
.NET.  I posted earlier about having some difficulty, all that is resolved
so thanks for the help.  I ran into another issue, using Glade# on .NET.

Basically what I found was glade-sharp.dll from the .08 win32 install
package was old, so I carried over mine from my linux box thats fresh from
CVS, all is great so far.  When I run my example it says can't find
glade-2.0 so after talking to some GTK people libglade is missing.  So I
hunt and try different libglades, different filenames, and eventually
Johannes helped me today and he found out that it was searching for
glade-2.0 as the filename, no .dll extention, and wam it worked.  So
basically its trying to PInvoke the wrong filename in my opinion.

This is basically what VS.NET was reporting:
An unhandled exception of type 'System.DllNotFoundException' occurred in
Additional information: Unable to load DLL (glade-2.0).

Also as a side note, could a new glade-sharp.dll be packaged with the win32
installer, as well as when this issue is resolved, glade-2.0.dll?

Basically its working for me now, although no extensive tests, but it did
pop up my window and button from a glade file using the filename glade-2.0
with no extention.

Take care and thanks,

Simon Guindon
Nureality Networks